FastNetMon

суббота, 30 января 2010 г.

Установка Perl фреймворка Catalyst на Debian 5 Lenny с Perl 5.10

Сначала ставим сам CPAN:

apt-get install perl


Теперь поставим всё необходимое для сборки XS модулей (написанных на С) и в т.ч.команду make:
apt-get install gcc make



Обновим сам CPAN:
cpan YAML Bundle::CPAN


Теперь обновим все Perl модули, имеющиеся в системе:

cpan
cpan_shell: upgrade


У меня не обновились лишь следующие модули, но т.к. я их не использую, мне это не интересно:

DB_File 1.816_1 1.819 PMQS/DB_File-1.819.tar.gz
B 1.17 1.19 NWCLARK/perl-5.8.9.tar.gz



Ну и, наконец, поставим сам Catalyst:
cpan Task::Catalyst Catalyst::Devel


Не знаю, как у Вас, но у меня не встал лишь модуль: Catalyst::Plugin::Session::State::URI

Который придётся поставить насильно:

cpan
cpan_shell: force install Catalyst::Plugin::Session::State::URI


После этого надо повторить команды, которые мы использовали для установки Каталиста.

В итоге нас должна встретить вот такая прелестная надпись:

Task::Catalyst is up to date (3.0000).
Catalyst::Devel is up to date (1.10)


Попутно возникла идея сделать свой аналог http://search.cpan.org/~mramberg/Task-Catalyst-3.0000/lib/Task/Catalyst.pm куда включить наиболее часто используемые, на мой взгляд, модули. Причем, как и ожидалось, пакетная инсталляция там решаться через толстый Makefile.PL :)

Комментариев нет :

Отправить комментарий

Примечание. Отправлять комментарии могут только участники этого блога.