FastNetMon

суббота, 6 ноября 2010 г.

Сборка rpm 4.8 на Debian 5 Lenny

Возникла необходимость работы с RPM пакетами от Fedora 14, но они категорически не понимаются RPM версии 4.4, которая стандартная в Дебияне. Так что будем собирать 4.8 версию :)

Вот тут берем исходники: http://www.rpm.org/wiki/Releases/4.8.1

Ставим зависимости для RPM 4.4 (он в репозитории):
apt-get build-dep rpm -y

Доставляем зависимости для 4.8:
apt-get isntall -y libnspr4-dev libnss3-dev libmagic-dev

Компилируем:
cd /usr/src/
wget http://rpm.org/releases/rpm-4.8.x/rpm-4.8.1.tar.bz2
tar -xf rpm-4.8.1.tar.bz2
cd rpm-4.8.1
# без CPPLAGS configure не видит хидеры nss/nspr по пути /usr/include/nss
# без флажка --with-external-db RPM будет требовать внешнего BDB, то есть, не системного
# это сделано по соображениям безопасности, чтобы апдейт BDB не свалил базу RPM
# --with-external-db --without-lua для отключения поддержки lua,
# которая упорно у меня не находилась в системе
./configure --prefix /opt/rpm48 CPPFLAGS="`pkg-config --cflags nss`" --with-external-db --without-lua
make
make install

Вуаля:
/opt/rpm48/bin/rpm --version
RPM version 4.8.1

Комментариев нет :

Отправить комментарий

Примечание. Отправлять комментарии могут только участники этого блога.