FastNetMon

пятница, 16 ноября 2012 г.

ошибка: "ploop-lib-1.4-1" задает несколько пакетов

Либо на английском:
LANG=C rpm -e --nodeps ploop ploop-lib
error: "ploop-lib" specifies multiple packages
Внешне это выглядит как сущий абсурд:
rpm -qa|grep ploop
ploop-lib-1.4-1
ploop-lib-1.4-1

На деле же это два разных пакета, но про разные архитетуры:
rpm -q --queryformat "%{name}.%{arch}\n"  ploop-lib
ploop-lib.x86_64
ploop-lib.i386

Фикс:
rpm -e --nodeps ploop-lib.x86_64
rpm -e --nodeps ploop-lib.i386
Источник: http://linuxhostingsupport.net/blog/rpm-remove-error-specifies-multiple-packages 

Комментариев нет :

Отправить комментарий

Примечание. Отправлять комментарии могут только участники этого блога.