FastNetMon

вторник, 12 марта 2013 г.

Установка mod_adobe_crossdomainpolicy.c на Debian 6

Устаналивать будем на Apache Worker.
cd /usr/src
mkdir adobe
cd adobe
wget http://www.beamartyr.net/projects/mod_adobe_crossdomainpolicy.c
# for apache worker
apt-get install -y libapr1-dev apache2-threaded-dev
apxs2 -cia mod_adobe_crossdomainpolicy.c


После этого в системе будет создан файл для загрузки модуля:
cat /etc/apache2/mods-available/adobe_crossdomainpolicy.load
LoadModule adobe_crossdomainpolicy_module /usr/lib/apache2/modules/mod_adobe_crossdomainpolicy.so
vim /etc/apache2/conf.d/adobe_crossdomain.conf

А содержимое, пожалуйста, возьмите по адресу (угловые скобки в Блоггере - это просто ад!): http://www.beamartyr.net/articles/adobepolicyfileserver.html)

 
Чтобы проверить, что все подцепилось воспользуйтесь командой с первоисточника.

Также я рекомендую в случае большого числа сообщений вида:
[Fri Mar 15 14:29:31 2013] [warn] [client 195.114.240.32] Invalid request: UERY_STRING}&area=memberIspViewer [L] (0 bytes) 

В логе сделать патч:

-ap_log_cerror(APLOG_MARK, APLOG_WARNING, 0,c, "Invalid request: %s (%d bytes)", data, size);
+ap_log_cerror(APLOG_MARK, APLOG_DEBUG, 0,c, "Invalid request: %s (%d bytes)", data, size);


Источник: http://www.beamartyr.net/articles/adobepolicyfileserver.html


Комментариев нет :

Отправить комментарий

Примечание. Отправлять комментарии могут только участники этого блога.