FastNetMon

Показаны сообщения с ярлыком gem. Показать все сообщения
Показаны сообщения с ярлыком gem. Показать все сообщения

понедельник, 15 ноября 2010 г.

Установка обновленного gem в Debian

При попытке обновить gem правильным способом на Debian гарантированно вылетает ошибка:
gem update --system is disabled on Debian. RubyGems can be updated using the official Debian repositories by aptitude or apt-get.

gem install rubygems-update
cd /var/lib/gems/1.8/bin
./update_rubygems

Источник: http://programmers-blog.com/2009/04/12/ruby-gem-update-system-is-disabled-on-debian

воскресенье, 1 августа 2010 г.

ERROR: While executing gem ... (...) bad response Moved Permanently 301

Имеем вот такую ошибку:

gem list -r

*** REMOTE GEMS ***

ERROR: While executing gem ... (Gem::RemoteFetcher::FetchError)
bad response Moved Permanently 301 (http://gems.rubyforge.org/latest_specs.4.8)


Делаем следующее:
gem sources -a http://production.s3.rubygems.org/
gem sources -r http://gems.rubyforge.org/


Взято с: http://www.zeux.at/node/54